Thread vim 7.3 - Problem mit folding (19 answers)
Opened by pq at 2010-09-14 20:01

pq
 2011-03-19 13:12
#146655 #146655
User since
2003-08-04
12208 articles
Admin1
[Homepage]
user image
also bei mir ist es zwar ähnlich, aber ich hab zusätzlich noch das problem, dass es auch auftritt, wenn ich keine quotes eingebe. also:
meine abgespeckte .vimrc:
Code: (dl )
1
2
let perl_fold=0
syntax on

(interessanterweise macht es keinen unterschied, ob ich perl_fold auf 1 oder 0 setze)

befinde mich in CGI.pm vor der sub can:
Code: (dl )
1
2
3
4
# Custom 'can' method for both autoloaded and non-autoloaded subroutines.
# Author: Cees Hek <cees@sitesuite.com.au>

+--- 23 Zeilen: sub can {------------------------------------------------------------------------

und tippe einfach nur return. dauert es 2-3 sekunden, bis ich tippen kann. wenn ich dann anfange, zu tippen, z.b. einfach nur: test, dann dauert das auch wieder 4 sekunden, bis es erscheint. (die sub bleibt dabei aber immer eingeklappt)

vielleicht sollte ich mal herausfinden, ob da noch woanders irgendwelche syntaxdateien per default geladen werden...

edit: und auch wenn alle subs schon ausgeklappt sind, tritt der effekt auf. aber wenn ich perl_fold komplett aus der vimrc rauswerfe, tritt der effekt nicht auf. hat also irgendwas mit dem folding zu tun. mag aber gar nicht drauf verzichten...
Last edited: 2011-03-19 13:26:34 +0100 (CET)
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. -- Damian Conway in "Perl Best Practices"
lesen: Wiki:Wie frage ich & perlintro Wiki:brian's Leitfaden für jedes Perl-Problem

View full thread vim 7.3 - Problem mit folding