Thread [LWP::UserAgent] "Ein nicht blockierender Socketvorgang konnte nicht sofort ausgeführt werden" (Perl 5.18 64bit) (33 answers)
Opened by bianca at 2015-03-23 07:43

bianca
 2015-03-23 07:43
#180277 #180277
User since
2009-09-13
6976 articles
BenutzerIn

user image
Guten Morgen!
In einem neuen Script versuche ich mittels CPAN:LWP::UserAgent eine gesicherte Verbindung zu einem Dienstleister herzustellen. Leider erhalte ich dabei aber ständig den Fehler "Ein nicht blockierender Socketvorgang konnte nicht sofort ausgeführt werden."

Ich verwende auf Win 7 64 Bit folgendes Strawberry: perl 5, version 18, subversion 4 (v5.18.4) built for MSWin32-x64-multi-thread sowie
CPAN:LWP::UserAgent 6.06
CPAN:IO::Socket::SSL 2.012
CPAN:Net::SSLeay 1.66

Eine Textsuche in sämtlichen installierten Modulen brachte kein Erfolg. Ich wundere mich eh, dass die Meldung deutsch ist.
Auf http://forum.fhem.de/index.php?topic=28247.0 muss die Lösung wohl darin gelegen haben, dass ein 32 Bit Perl verwendet wurde, wegen "nonblocking request". Das ist ja bei mir nicht der Fall also denke ich, dass der Fehler woanders liegt. Aber wo? Bitte um eure Hilfe.

modedit Editiert von GwenDragon: Titel
Last edited: 2015-03-23 12:12:55 +0100 (CET)
10 print "Hallo"
20 goto 10

View full thread [LWP::UserAgent] "Ein nicht blockierender Socketvorgang konnte nicht sofort ausgeführt werden" (Perl 5.18 64bit)