Thread Win32: Suche mod_perl für Apache 2.4 + Strawberry Perl (5 answers)
Opened by GwenDragon at 2016-06-28 10:57

GwenDragon
 2016-06-28 10:57
#184970 #184970
User since
2005-01-17
13710 articles
Admin1
[Homepage]
user image
Hat jemand Wissen, wo ich ein lauffähige Binaries für Apache 2.4 (32bit) + mod_perl (32bit) + Strawberry Perl (32bit) herbekomme? Mein OS ist Windows 10 x64 und Perl >= 5.20.

Ich habe schon die Apaches von ApacheHaus und ApacheLounge probiert.
Aber Steve Hays mod_perl Modul wird einfach nicht geladen.

Die Konfig besteht zum Test aus dem Schnippsel:
Code: (dl )
1
2
3
4
SetEnv PERL5LIB C:/strawberry/perl/lib;C:/strawberry/perl/site/lib;C:/strawberry/perl/vendor/lib

LoadFile C:/strawberry/perl/bin/perl520.dll
LoadModule perl_module modules/mod_perl.so


Aus irgendeinem Grund wird das Modul zwar gefunden, aber ein Einsprungpunkt wird wohl nicht gefunden :(

httpd.exe: Syntax error on line 533 of X:/usr/local/apache2/conf/httpd.conf: Cannot load modules/mod_perl.so into server: Die angegebene Prozedur wurde nicht gefunden.

Kann mir da jemand helfen?

Es ist nervig, selbst so träge mit Updates versogrte OS wie Debian haben längst Apache 2.4 und mod_perl 2.0.9.
Nur Windows ist da wieder Jahre zurück.

//EDIT:
Die mod_perl-Module von Steve Hay laden nur in Apache 2.2 :(
Das ist aber problematisch, da Apache 2.2 EOL ist und ich auf 2.4 und neuerem Perl entwickeln muss.
Last edited: 2016-06-28 12:28:49 +0200 (CEST)
die Drachin, Gwendolyn.


Unterschiedliche Perl-Versionen auf Windows (fast wie perlbrew) • Meine Perl-Artikel

View full thread Win32: Suche mod_perl für Apache 2.4 + Strawberry Perl