Thread Problem mit älterem CGI-Script nach Apache-Update (3 answers)
Opened by Cornelio at 2017-03-06 23:33

guest Cornelio
 2017-03-06 23:33
#186216 #186216
Hallo Perl-Nonnen und -Mönche,

ich habe hier ein älteres CGI-Script, mit dem mp3-Dateien zum Download ausgeliefert werden. Seit einem Update des Apache auf Version 2.2.22 kommt eine Fehlermeldung, die offenbar von dieser Stelle verursacht wird:

Code (perl): (dl )
1
2
3
4
5
6
print $q->header({
    -type=>'application/octet-stream'
    , -nph=>1
    , -attachment=>$audioDatei
    , -Content_length=>$fileSize
});

Die Meldung:
Code: (dl )
1
2
Error message:
malformed header from script. Bad header=HTTP/1.1 200 OK: ...

Wie gesagt hat das Script seit Jahren funktioniert. Hat jemand eine Idee, was hier passiert ist?

Vielen Dank und viele Grüße!
Last edited: 2017-03-07 00:02:02 +0100 (CET)

View full thread Problem mit älterem CGI-Script nach Apache-Update