Thread version kaputt? (14 answers)
Opened by bianca at 2018-06-15 18:15

bianca
 2018-06-15 18:15
#188532 #188532
User since
2009-09-13
6583 articles
BenutzerIn

user image
Habe mich gerade darĂ¼ber erschrocken, dass hier bei mir mit folgendem Script "wahr" ausgegeben wird.
Ist das bei euch auch?
Ist das denn richtig? Ich erwarte hier definitiv keine Ausgabe, weil doch 1.2.4 nicht kleiner als 1.1 ist!?
Code (perl): (dl )
1
2
3
4
5
6
7
8
#!/usr/bin/perl
use strict;
use warnings;
use 5.010;

if (version->parse('1.2.4') <= version->parse('1.1')) {
    say "wahr";
}
10 print "Hallo"
20 goto 10

View full thread version kaputt?