Thread Crypt::LE und Fehler 'No Key ID in JWS header' (15 answers)
Opened by bianca at 2021-08-06 11:41

bianca
 2021-08-07 15:23
#193514 #193514
User since
2009-09-13
6751 articles
BenutzerIn

user image
2021-08-07T12:03:49 styx-cc
wenn das zu schlechter Stil ist einfach nur einen link zu posten, bitte bescheid geben.
Nein alles ist gut.

2021-08-07T12:03:49 styx-cc
Das hatte ich auch schon gefunden, kann damit aber nichts anfangen.

2021-08-07T12:03:49 styx-cc
insbesondere den (vor)letzten Beitrag
Im Vorletzten wird ein ClusterIssuer neu erzeugt. Was ist das und wofür und wo und wie? Das sagt mir absolut gar nichts. Hast dazu jemand einen Tipp?
Und im Letzten finde ich nur Befunde ohne Lösung.
Übersehe ich was?

2021-08-07T12:03:49 styx-cc
Edit: Bzw. du hast einen selbst geschriebenen Clienten geupdate so wie ich das auf die Schnelle verstanden habe - was aber in der Konsequenz zum gleichen Problem führen kann
Der Client an sich ist ein eigenes Script was das CPAN Paket CPAN:Crypt::LE nutzt.

Beim ersten Erneuerungsversuch mit der Version 0.37 hatte ich Fehler ACMEv1 is deprecated and you can no longer get certificates from this endpoint. Please use the ACMEv2 endpoint, you may need to update your ACME client software to do so. Visit https://community.letsencrypt.org/t/end-of-life-pl... for more information.

Dann habe ich auf 0.38 geupdatet und bekam mit selben Schlüsseldateien und Kommandos den Cannot request challenges - No Key ID in JWS header(400)

Ein Versuch mit dem Parameter version war erfolglos was aber auch nachvollziehbar ist, denn laut Debug wird automatisch die korrekte Version 2 geschaltet.
10 print "Hallo"
20 goto 10

View full thread Crypt::LE und Fehler 'No Key ID in JWS header'