Font
Wiki:Tipp zum Debugging: use Data::Dumper; local $Data::Dumper::Useqq = 1; print Dumper \@var;
[thread]3207[/thread]

swap schuld?

Reader: 1


<< |< 1 2 3 4 ... 6 >| >> 57 entries, 6 pages
Froschpopo
 2006-05-22 20:12
#30100 #30100
User since
2003-08-15
2653 articles
BenutzerIn
[default_avatar]
Folgendes problemchen beschäftigt mich... ich bekomme seit einiger zeit in meiner apache2 error_log folgende ausgabe:
Code: (dl )
[error] server reached MaxClients setting, consider raising the MaxClients setting



Ich habe den Verdacht, dass er irgendwie anfängt zu swappen. Dass dies erheblich die performance verringern könnte ist meine vermutung.
Oder lieg ich mal wieder falsch?
jan
 2006-05-22 20:24
#30101 #30101
User since
2003-08-04
2536 articles
ModeratorIn
[Homepage] [default_avatar]
mh. das könnte auch ganz einfach sein, dass du einen niedrigen MaxClients-Wert gesetzt hast und wenn eben viel los ist, dann treibt er die anzahl der worker hoch und gelangt ans limit.
pq
 2006-05-22 20:25
#30102 #30102
User since
2003-08-04
12204 articles
Admin1
[Homepage]
user image
hast du schonmal daran gedacht, MaxClients hochzusetzen?
außerdem bist du doch auf einer linux-kiste, da kann man statt
vermuten auch gerne mal so tolle tools wie free, ps oder top ausprobieren.
gerne in verbindung mit watch.
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. -- Damian Conway in "Perl Best Practices"
lesen: Wiki:Wie frage ich & perlintro Wiki:brian's Leitfaden für jedes Perl-Problem
Froschpopo
 2006-05-22 20:34
#30103 #30103
User since
2003-08-15
2653 articles
BenutzerIn
[default_avatar]
top sagt ja eindeutig, dass swap genutzt wird ! aber betrifft das dann auch mod_perl automatisch? und sollte ich dann noch MaxClients erhöhen?

mein swap ist 795176 groß, davon werden 207296 genutzt...

das liegt wohl daran, dass dieser server ohnehin mit 264 mb recht wenig ram hat. aber ich hab nichtmal nen x-server oder sowas laufen...

lohnt sich bei nem 3,2 GB Prozessor vielleicht ein unswap?\n\n

<!--EDIT|Froschpopo|1148316028-->
GwenDragon
 2006-05-22 21:44
#30104 #30104
User since
2005-01-17
14198 articles
Admin1
[Homepage]
user image
Setz bloss nicht MaxClients hoch.
Das drückt enorm die Performance!
Am besten MaxClients auf 4 setzen. Da starten dann mehr Prozesse und das bringt Speed.

Außerdem schff dir einen Server mit 4.5 GHz an. Dann kann der Apache schneller die Verbindungen aufbauen. Zudem reicht dann bei der Geschwindigkeit auch 256 MB Ram aus.

Oder einen Server mit 5 Blades! Das macht Speed, jawoll.\n\n

<!--EDIT|GwenDragon|1148319928-->
die Drachin, Gwendolyn


Unterschiedliche Perl-Versionen auf Windows (fast wie perlbrew) • Meine Perl-Artikel

Froschpopo
 2006-05-22 22:20
#30105 #30105
User since
2003-08-15
2653 articles
BenutzerIn
[default_avatar]
also ich hab die sekunde bis zu 20 gleichzeitige requests, wie soll ich die mit 4 denn bewältigen??????
Im moment klappts ja super, ich bin nur der meinung, dass man da noch etwas mehr rausholen kann ... warum soll ich maxclients auf 4 setzen?
pq
 2006-05-22 23:15
#30106 #30106
User since
2003-08-04
12204 articles
Admin1
[Homepage]
user image
wann du dir vielleicht endlich mal anschauen würdest, wieviel speicher deine
mod_perl-prozesse so verbrauchen, dann könnte man vielleicht
noch eher tips geben.
256MB find ich persönlich zu wenig.
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. -- Damian Conway in "Perl Best Practices"
lesen: Wiki:Wie frage ich & perlintro Wiki:brian's Leitfaden für jedes Perl-Problem
Froschpopo
 2006-05-22 23:25
#30107 #30107
User since
2003-08-15
2653 articles
BenutzerIn
[default_avatar]
und wie krieg ich raus wieviel ein einzelnes programm swap verbrauchen`?
ptk
 2006-05-22 23:42
#30108 #30108
User since
2003-11-28
3645 articles
ModeratorIn
[default_avatar]
[quote=Froschpopo,22.05.2006, 18:12]Folgendes problemchen beschäftigt mich... ich bekomme seit einiger zeit in meiner apache2 error_log folgende ausgabe:
Code: (dl )
[error] server reached MaxClients setting, consider raising the MaxClients setting



Ich habe den Verdacht, dass er irgendwie anfängt zu swappen. Dass dies erheblich die performance verringern könnte ist meine vermutung.
Oder lieg ich mal wieder falsch?[/quote]
Wenn du mod_perl verwendest, dann ignorier die Meldung einfach. Setz einfach deine MaxClients-Einstellung so hoch, dass niemals geswappt wird, und dann ist gut.\n\n

<!--EDIT|ptk|1148326968-->
Froschpopo
 2006-05-23 00:00
#30109 #30109
User since
2003-08-15
2653 articles
BenutzerIn
[default_avatar]
niemals geswappt wird, wenn ich maxClients auf 6 setze. Aber dann dauert der einzelne Request fast 2 Minuten und das ist deutlich zu hoch! Da war ich bei MaxClients 25 mit nur einer halben Sekunde deutlich schneller, trotz swap !!

Dass er überhaupt grundsätzlich swapped scheint schon am apache2 zu liegen, denn der swapp ist sofort weg, wenn ich den server kurz stoppe.

Zur weiteren Info:

StartServers 15
MinSpareServers 15
MaxSpare Servers 19
ServerLimit
MaxClients 25
MaxRequestsPerChild 0\n\n

<!--EDIT|Froschpopo|1148328155-->
<< |< 1 2 3 4 ... 6 >| >> 57 entries, 6 pages



View all threads created 2006-05-22 20:12.