Font
[thread]9449[/thread]

UTF für Forum

Reader: 1


<< |< 1 2 3 4 >| >> 34 entries, 4 pages
GwenDragon
 2005-11-30 17:41
#89043 #89043
User since
2005-01-17
14482 articles
Admin1
[Homepage]
user image
Ist es möglich das Board auf UTF-8 um zu stellen?
Dann könnte eine auch Sonderzeichen eingeben.
die Drachin, Gwendolyn


Unterschiedliche Perl-Versionen auf Windows (fast wie perlbrew) • Meine Perl-Artikel

esskar
 2005-11-30 18:00
#89044 #89044
User since
2003-08-04
7321 articles
ModeratorIn

user image
müsste man wohl patchen ...
weiß aber nicht wie sich das auswirkt ...
hab ich eigentlich keine Lust zu auch wenn ich auch dafür wäre ...
format_c
 2005-11-30 18:03
#89045 #89045
User since
2003-08-04
1706 articles
HausmeisterIn
[Homepage] [default_avatar]
Ist doch nur n header Option:
Code: (dl )
print CGI::header(-charset=>'utf-8');

Wirkt sich auf die bestehenden Beiträge gar nicht aus, da die ersten 2 byte genau dem ISO-8859-15 Zeichensatz entsprechen.

Gruß Alex\n\n

<!--EDIT|format_c|1133366725-->
anti
 2005-11-30 18:12
#89046 #89046
User since
2003-11-29
155 articles
BenutzerIn
[default_avatar]
[quote=GwenDragon,30.11.2005, 16:41]Ist es möglich das Board auf UTF-8 um zu stellen?[/quote]

Dazu ist afaik Apache 2.x notwendig und das Forum nutzt leider:

Quote
Apache/1.3.28 Server at board.perl-community.de Port 80


greetz, anti
esskar
 2005-11-30 18:12
#89047 #89047
User since
2003-08-04
7321 articles
ModeratorIn

user image
und wie sieht es mit der datenbank aus?
ich kann es naccher mal testen... bin aber noch auf der arbeit und hab von hier aus keinen zugang (bzw. die zugangsdaten nicht griffbereit)
anti
 2005-11-30 18:21
#89048 #89048
User since
2003-11-29
155 articles
BenutzerIn
[default_avatar]
[quote=esskar,30.11.2005, 17:12]und wie sieht es mit der datenbank aus?
[/quote]

Ich kann nur für mysql sprechen und da sollte es keine Probleme geben!

greetz, anti
Taulmarill
 2005-11-30 18:55
#89049 #89049
User since
2004-02-19
1750 articles
BenutzerIn

user image
hier mal nen paar utf-8 chars üäö²³µ
$_=unpack"B*",~pack"H*",$_ and y&1|0& |#&&print"$_\n"for@.=qw BFA2F7C39139F45F78
0A28104594444504400 0A2F107D54447DE7800 0A2110453444450500 73CF1045138445F4800 0
F3EF2044E3D17DE 8A08A0451412411 F3CF207DF41C79E 820A20451412414 83E93C4513D17D2B
Taulmarill
 2005-11-30 18:57
#89050 #89050
User since
2004-02-19
1750 articles
BenutzerIn

user image
scheint zu funktionieren, wenn ich im firefox die view auf utf-8 umstelle, werden die sonderzeichen oben richtig dargestellt. dafür kann ich die anderen umlaute auf der seite nicht mehr sehen.
$_=unpack"B*",~pack"H*",$_ and y&1|0& |#&&print"$_\n"for@.=qw BFA2F7C39139F45F78
0A28104594444504400 0A2F107D54447DE7800 0A2110453444450500 73CF1045138445F4800 0
F3EF2044E3D17DE 8A08A0451412411 F3CF207DF41C79E 820A20451412414 83E93C4513D17D2B
esskar
 2005-11-30 19:16
#89051 #89051
User since
2003-08-04
7321 articles
ModeratorIn

user image
[quote=Taulmarill,30.11.2005, 17:57]scheint zu funktionieren, wenn ich im firefox die view auf utf-8 umstelle, werden die sonderzeichen oben richtig dargestellt. dafür kann ich die anderen umlaute auf der seite nicht mehr sehen.[/quote]
das heißt, dass wir dann nur noch utf-8 können, die alten beiträge aber falsch bleiben!?!
Taulmarill
 2005-11-30 19:22
#89052 #89052
User since
2004-02-19
1750 articles
BenutzerIn

user image
naja, von latin-1 nach utf-8 zu konvertieren ist nicht so das problem. anders herum schon eher, da es natürlich nicht für jedes utf-8 zeichen eines im latin-1 zeichensatz geben kann.

was du mit "nur noch utf-8 können" meinst, weiss ich jetzt nicht so genau...
$_=unpack"B*",~pack"H*",$_ and y&1|0& |#&&print"$_\n"for@.=qw BFA2F7C39139F45F78
0A28104594444504400 0A2F107D54447DE7800 0A2110453444450500 73CF1045138445F4800 0
F3EF2044E3D17DE 8A08A0451412411 F3CF207DF41C79E 820A20451412414 83E93C4513D17D2B
<< |< 1 2 3 4 >| >> 34 entries, 4 pages



View all threads created 2005-11-30 17:41.