Font
Wiki:Tipp zum Debugging: use Data::Dumper; local $Data::Dumper::Useqq = 1; print Dumper \@var;
[thread]12987[/thread]

Newbie -Keine Ausgabe bei mysql-query (page 3)

Readers: 2


<< |< 1 2 3 4 5 6 7 >| >> 63 entries, 7 pages
Struppi
 2009-01-14 14:46
#117959 #117959
User since
2006-02-17
628 articles
BenutzerIn
[Homepage]
user image
deletemast+2009-01-14 13:23:27--
perl -v ergibt: 5.10.0
genau aus dem Grund, brauchst du die Repositories die Rene ;-) dir genannt hat. Das mysql Modul ist in dieser Version noch nicht über activeState verfügbar, warum auch immer.
deletemast
 2009-01-14 15:14
#117962 #117962
User since
2009-01-14
23 articles
BenutzerIn
[default_avatar]
trouchelle habe ich als xml Datei heruntergeladen... und nun?
uwinnipeg habe ich entzippt und install.pl ausgeführt
nun habe ich ein weiteres Verzeichnis unterhalb von Perl/lib/ PPM
in diesem Verzeichnis befindet sich die Datei: Repositories.pm
wie ist nun die Vorgehensweise um die fehlenden Komponente zu installieren?

Danke für Eure Hilfe
renee
 2009-01-14 15:25
#117965 #117965
User since
2003-08-04
14371 articles
ModeratorIn
[Homepage] [default_avatar]
Nein, Du musst PPM starten und im Menü die Einstellungen finden. Ich glaube unter "View" -> "Preferences" oder so ähnlich.

Dort gibt es dann einen Reiter "Repositories". Dort kannst Du dann einen Namen und die URL zu dem Repository eintragen und dann "Add" klicken.
OTRS-Erweiterungen (http://feature-addons.de/)
Frankfurt Perlmongers (http://frankfurt.pm/)
--

Unterlagen OTRS-Workshop 2012: http://otrs.perl-services.de/workshop.html
Perl-Entwicklung: http://perl-services.de/
deletemast
 2009-01-14 15:26
#117966 #117966
User since
2009-01-14
23 articles
BenutzerIn
[default_avatar]
Habe über den Package Manager nun trouchelle und uwnnipeg hinzugefügt,
Database wurde synchronisiert
Leider wird DBD-mysql immer noch nicht mit aufgeführt...?

Was habe ich vergessen bzw. Falsch gemacht?
renee
 2009-01-14 15:35
#117967 #117967
User since
2003-08-04
14371 articles
ModeratorIn
[Homepage] [default_avatar]
Öffne ne DOS-Box ("Start" -> "Ausführen..." -> "cmd.exe") und gib dort folgendes ein:

Code: (dl )
ppm install http://cpan.uwinnipeg.ca/PPMPackages/10xx/DBD-mysql.ppd
OTRS-Erweiterungen (http://feature-addons.de/)
Frankfurt Perlmongers (http://frankfurt.pm/)
--

Unterlagen OTRS-Workshop 2012: http://otrs.perl-services.de/workshop.html
Perl-Entwicklung: http://perl-services.de/
deletemast
 2009-01-14 16:40
#117976 #117976
User since
2009-01-14
23 articles
BenutzerIn
[default_avatar]
Die Repositories wurden hinzugefügt, jetzt wird auch DBD-mysql angezeigt aber nicht unter "installierte Packages" sondern unter alle
auf rechtsklick und install passiert nicht viel...
pktm
 2009-01-14 16:44
#117977 #117977
User since
2003-08-07
2921 articles
BenutzerIn
[Homepage]
user image
deletemast+2009-01-14 15:40:33--
Die Repositories wurden hinzugefügt, jetzt wird auch DBD-mysql angezeigt aber nicht unter "installierte Packages" sondern unter alle
auf rechtsklick und install passiert nicht viel...


ActiveState scheint mit dieser Frage gerechnet zu haben und hat etwas für dich geschrieben. Es ist oben in der Leiste von ppm im Punkt Help > Contents versteckt.

Hier die Kurzfassung:
- suche das Paket
- Klicke es an
- Drücke die +-Taste (Plustaste) auf deiner Tastatur
- Klicke mit der Maus auf den grünen Pfeil oben in der Leiste, der nach rechts zeigt.
http://www.intergastro-service.de (mein erstes CMS :) )
deletemast
 2009-01-14 17:21
#117981 #117981
User since
2009-01-14
23 articles
BenutzerIn
[default_avatar]
Super, das war's jetzt funktioniert meine simple SQL-Query (dbi4.pl)
allerdings bekomme ich immer noch keine Ausgabe von dbi2.pl und dbi3.pl im Browser.
Aber immerhin schon ein wichtiges Stück weiter
*freu*
pktm
 2009-01-14 17:51
#117985 #117985
User since
2003-08-07
2921 articles
BenutzerIn
[Homepage]
user image
Bei mir funktioniert das:
Code: (dl )
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#!/usr/bin/perl

=comment

dbi2.pl vorhandene Datenbanktreiber

=cut

use strict;
use warnings;
use DBI;
use CGI;

my $q = CGI->new();

#print "Content-type: text/html\n\n";
print $q->header();

my @drivers = DBI->available_drivers();

print "vorhandene Treiber:<br>";
foreach (@drivers){
print "$_<br>";
}


Du hast einen Tippfehler der foreach-Schleife. Dort steht bei dir @driver, du liest die Treiber aber in @drivers ein.
use strict; macht dich auf so etwas aufmerksam.
Irgendwo im Wiki gibt es einen Artikel dazu, warum du strict immer und überall verwenden solltest (kann den mal jemand verlinken?).
http://www.intergastro-service.de (mein erstes CMS :) )
pq
 2009-01-14 20:20
#117995 #117995
User since
2003-08-04
12208 articles
Admin1
[Homepage]
user image
Wiki:UseStrict
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. -- Damian Conway in "Perl Best Practices"
lesen: Wiki:Wie frage ich & perlintro Wiki:brian's Leitfaden für jedes Perl-Problem
<< |< 1 2 3 4 5 6 7 >| >> 63 entries, 7 pages



View all threads created 2009-01-14 01:45.