Font
Wiki:Tipp zum Debugging: use Data::Dumper; local $Data::Dumper::Useqq = 1; print Dumper \@var;
[thread]5392[/thread]

Lokale Testumgebung: Internal Server Error (page 3)



<< |< 1 2 3 4 >| >> 37 entries, 4 pages
Strat
 2003-12-05 01:28
#48491 #48491
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
was fuer eine perl-version hast du?
Code: (dl )
perl -V

und was gibt
Code: (dl )
assoc .pl 

in der shell aus? Perl oder so? und was gibt dann
Code: (dl )
ftype Perl

(oder Perl durch das ersetzen, was beim assoc herauskam)
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Alex
 2003-12-05 19:09
#48492 #48492
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Hallo, sorry das ich mich so lange nicht gemeldet habe, liege eigentlich mit einer gscheiten Grippe im Bett...
So Strat hier mal Deine Antworten:

C:\Dokumente und Einstellungen\Administrator> perl -v

This is perl, v5.8.1 built for MSWin32-x86-multi-thread
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2003, Larry Wall

Binary build 807 provided by ActiveState Corp. http://www.ActiveState.com
ActiveState is a division of Sophos.
Built 18:19:11 Nov 3 2003


Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'. If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.


C:\Dokumente und Einstellungen\Administrator>assoc.pl
.pl=Perl

C:\Dokumente und Einstellungen\Administrator>ftype Perl
Perl="C:\usr\bin\perl.exe" "%1" %*

C:\Dokumente und Einstellungen\Administrator>

ScriptInterpreterSource Registry habe ich auch noch reingeschrieben. Ohne Erfolg.

Werde nun mal Perl neuinstallieren, obwohl ich mir davon nicht viel verspreche... Bis gleich.
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
format_c
 2003-12-05 20:39
#48493 #48493
User since
2003-08-04
1706 articles
HausmeisterIn
[Homepage] [default_avatar]
Check mal dein Mail.
hab die mal meine default httpd.conf geschickt mit der es bei mir geht.

Gruß Alex
Strat
 2003-12-06 15:09
#48494 #48494
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
falls es nicht funktioniert, steig am besten auf apache 1.3 um, mit dem kenne ich mich recht gut aus. Es gibt da auch eine komplette Entwicklungsumgebung (Apache1.3, MySql, Perl, PHP, PhpMyAdmin, ...), die du von http://sourceforge.net/project/showfiles.php?group_id=61776 -> WAMPP 1.1 downloaden kannst. Es ist einfach zu installieren, und ist standardmaessig schon recht gut konfiguriert
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Alex
 2003-12-07 19:52
#48495 #48495
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Hi!

Es ist zum aus der Haut fahren!!!
@format_c: Danke für die Mail. Ergebnis trotz Anpassung waren endsviele Fehlermeldungen. Denke die config war für die 1.3 ...?

Egal.

Also Apache deinstalliert und die 1.3 installiert...
.. die gleiche Sch.... immer noch!!!

Ich habs doch schon mal auf meinem Rechner gehabt. Eigentlich nur komplett neu aufgestetzt und jetzt gehts nicht mehr...

Woran kann denn das nur liegen?
Apache läuft, sprich meine html-Seiten unter htdocs werden wunderbar angezeigt.
Perl läuft wie oben bewiesen auch.
nur .pl oder .cgi werden im Browser nicht ausgeführt...

Weiß noch jemand Rat?
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
Alex
 2003-12-07 20:44
#48496 #48496
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Und nochmal ein bißchen rumgespielt:
Zur Erinnerung das ok.pl von Strat:
Code: (dl )
1
2
3
4
5
#!c:/usr/bin/perl
use strict;
use warnings;
print "Content-type: text/html\n\n";
print "ok";

Habe in der shebang nur das "C:" hinzugefügt. Folgende Fehlermeldung im errorlog (Beim einmaligen Aufruf dieser ok.pl):

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Premature end of script headers: c:/apache/htdocs/cgi-bin/ok.pl
[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 2, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before t?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 2, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before r?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 2, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before i?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 2, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before c?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 2, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before t?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before w?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near "w"

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before r?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before n?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before i?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before n?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 3, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before g?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 4, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing semicolon on previous line?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 4, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before r?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 4, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before i?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 4, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before n?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 4, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before t?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] String found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 4, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before ?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 5, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before r?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 5, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before i?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 5, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before n?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Bareword found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 5, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before t?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] String found where operator expected at c:\apache\htdocs\cgi-bin\ok.pl line 5, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] (Missing operator before ?)

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] syntax error at c:\apache\htdocs\cgi-bin\ok.pl line 2, near ""

[Sun Dec 07 19:39:11 2003] [error] [client 127.0.0.1] Execution of c:\apache\htdocs\cgi-bin\ok.pl aborted due to compilation errors.

Also irgendwie kapier ich gar nix mehr...
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
Strat
 2003-12-07 20:52
#48497 #48497
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
laeuft denn das testscript, das beim wampp dabei ist? (env.cgi oder env.pl?)
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Alex
 2003-12-07 21:19
#48498 #48498
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
hab ich noch nicht probiert, baer dann hol ich mir halt jetzt doch das fertigpaket... weiß nicht warum, aber glücklich machen tut mich das nicht. ich meine es ging ja schon mal auf meinem rechner, es muss doch einen grund geben... bis gleich (hoffentlich mit einer erfolgsmeldung...
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
format_c
 2003-12-07 23:11
#48499 #48499
User since
2003-08-04
1706 articles
HausmeisterIn
[Homepage] [default_avatar]
stimmt die Shebang?
c:/usr/bin/perl???
Sollte der nicht bei standardinstallation c:/perl/bin/perl.exe lauten?

Gruß Alex
Alex
 2003-12-08 15:44
#48500 #48500
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Habs in c:usr/ installiert. der pfad stimmt. und die shebang habe ich in allen mir bekannten variationen ausprobiert: also z.b. mit C: oder auch mit perl.exe am schluss.
hab da ein idee, und würde wirklilch gerne wieder zum prog anfangen. mano...
ihr werdet mich jetzt auslachen, aber mit dem fertigpaket hab ich die installation nicht hinbekommen :blush: bin aber eh nicht so überzeug davon...
nein ich bin kein total doofy programme installieren und von pfaden etc. versteh ich eigentlich schon ein bißchen was!

wohnt von euch denn keiner in münchen? hätte hier noch ne gute flasche bordeaux rumstehen!...?
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
<< |< 1 2 3 4 >| >> 37 entries, 4 pages



View all threads created 2003-12-04 00:40.