Font
[thread]5392[/thread]

Lokale Testumgebung: Internal Server Error



<< |< 1 2 3 4 >| >> 37 entries, 4 pages
guest Gast
 2003-12-04 00:40
#48471 #48471
Guten Abend!

Habe gerade auf meinem Computer Apache installiert.
-> funzt eigentlich auch.

Perl habe ebenfalls installiert. Pfade sollten eigentlich stimmen.

Wenn ich nun aber das allseits bekannte hello.pl im Browser ausführen will, bekomme ich einen Internal Server Error.

Apache liegt in c:Apache2/bin/
Perl in c:usr/bin/perl/

Mein hello.pl

Code: (dl )
1
2
3
4
#!c:/usr/bin/perl.exe -w

print "Content-type: text/html\n\n";
print "<h3>Hello World</h3>";


Kommt jemand drauf woran es liegen kann?
Vielen Dank für Eure Hilfe.
Gruß Alex
Strat
 2003-12-04 00:51
#48472 #48472
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
schau mal in der error.log (muesste in c:\apache2\log\ liegen) nach, ob zu diesem Zeitpunkt eine Fehlermeldung auftaucht, und poste die hier.
Ich vermute mal, dass es beim Aufruf des Perl-Interpreters Probleme gibt
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Alex
 2003-12-04 00:57
#48473 #48473
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Hallo Strat!

Gesagt, getan:

error log:

[Wed Dec 03 23:58:10 2003] [error] [client 127.0.0.1] C:/Apache2/htdocs/cgi-bin/hello.pl is not executable; ensure interpreted scripts have "#!" first line
[Wed Dec 03 23:58:10 2003] [error] [client 127.0.0.1] (9)Bad file descriptor: don't know how to spawn child process: C:/Apache2/htdocs/cgi-bin/hello.pl

Was sagt uns das?
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
Strat
 2003-12-04 01:05
#48474 #48474
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
das bedeutet, dass er nicht weiss, womit er das script ausfuehren soll.
Versuche vielleicht mal als Shebang:
Code: (dl )
1
2
3
4
5
#! /usr/bin/perl 
use strict;
use warnings;
print "Content-type: text/html\n\n";
print "ok";



Siehe auch Dokumentation zum Apache HTTP Server Version 2.0 auf deutsch, speziell: http://httpd.apache.org/docs-2.0/mod/core.html#scriptinterpretersource
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Strat
 2003-12-04 01:07
#48475 #48475
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
Versuch auch mal, das Script mit der Endung .cgi (anstelle von .pl) zu versehen. Ich kenne mich bei Apache2 noch nicht besonders gut aus (verwende immer noch 1.3), aber wenn es wie beim 1.3er ist, ist da standardmaessig nur .cgi als cgi-script erlaubt:
AddHandler cgi-script .cgi .pl

nebenbei: unter http://www.apachefriends.org/ findest du eine vorgefertigte entwicklungsumgebung, die aus Apache, MySql, Perl, PHP, PhpMyAdmin usw. besteht, einfach und gut dokumentiert zu installieren ist.
Ich verwende da jedoch noch die alte wampp-Version (die kann man sich aus dem Archiv downloaden), weil mod_perl fuer Apache2 noch im Beta-Stadium ist und man im Internet meistens Apache1.3 findet. Leider wird diese Schiene nicht mehr weiterentwickelt.

Bei Apache 1.3 (weiss nicht, wie die Option bei 2.0 heisst) kann man in der httpd.conf ueber die Option
ScriptInterpreterSource registry
angeben, dass cgi-Scripte ueber die Registry ueber die Dateiendung einem Proramm zugeordnet werden. Dies hat auch den grossen Vorteil, dass man den Shebang nicht immer umstellen muss, wenn man eine Seite auf einen anderen Webserver hochlaedt.\n\n

<!--EDIT|Strat|1070493092-->
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Alex
 2003-12-04 01:12
#48476 #48476
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Hi,

kommt der gleich Fehler wieder.
Das kann doch nicht so schwer sein.
Nutze übrigends W2k
Früher unter NT war das kein Prob.
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
Strat
 2003-12-04 01:28
#48477 #48477
User since
2003-08-04
5246 articles
ModeratorIn
[Homepage] [default_avatar]
kommt der fehler sowohl bei dem anderen shebang als auch bei der umbenennung des scriptes in ....cgi?
perl -le "s::*erlco'unaty.'.dk':e,y;*kn:ai;penmic;;print"
http://www.fabiani.net/
Alex
 2003-12-04 01:33
#48478 #48478
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
ja, sowohl als auch...
? ? ? :rock:\n\n

<!--EDIT|Alex|1070494478-->
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
Alex
 2003-12-04 01:36
#48479 #48479
User since
2003-12-04
285 articles
BenutzerIn
[default_avatar]
Kann ich in der config vom apache was vergessen haben?
<center>Schönen Gruß, Alex
Mit dem Computer geht alles viel schneller - es dauert nur ein bißchen länger!
</center>
format_c
 2003-12-04 09:57
#48480 #48480
User since
2003-08-04
1706 articles
HausmeisterIn
[Homepage] [default_avatar]
Also die Fehlermeldung hatte ich auch mal auf meinem Apache auf Windows.
Ist nur ne Sache der Config.

Weis zwar nicht mehr wo genau der Fehler lag, aber es ist auf jeden Fall durch anpassen der Config-Datei zu beheben.

Gruß Alex
<< |< 1 2 3 4 >| >> 37 entries, 4 pages



View all threads created 2003-12-04 00:40.