Font
[thread]5404[/thread]

DBI unter WIN-XP installieren: weshalb funktioniert ppm nicht ? (page 2)



<< |< 1 2 3 4 >| >> 36 entries, 4 pages
havi
 2004-02-18 11:38
#48625 #48625
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Baerli wrote: # von anderem Thread kopiert...

Da der Thread verschwunden ist, nochmal

Immer, wenn ich DBI einbinde (Use DBI;) erhalte ich folgende
Fehlermeldung:
Code: (dl )
1
2
Can't locate loadable object for module DBI in @INC (@INC contains: C:/Perl/lib/MSWin32-x86-multi-thread C:/Perl/lib C:/Perl/site/lib .) at C:/Perl/lib/DBI.pm line 182
BEGIN failed--compilation aborted at C:/Perl/lib/DBI.pm line 182


Er wird ausgelöst durch DBI.pm (BEGIN)
Code: (dl )
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
BEGIN {
@ISA = qw(Exporter DynaLoader);

# Make some utility functions available if asked for
@EXPORT = (); # we export nothing by default
@EXPORT_OK = ('%DBI'); # populated by export_ok_tags:
%EXPORT_TAGS = (
sql_types => [ qw(
SQL_ALL_TYPES
SQL_CHAR SQL_NUMERIC SQL_DECIMAL SQL_INTEGER SQL_SMALLINT
SQL_FLOAT SQL_REAL SQL_DOUBLE SQL_VARCHAR
SQL_DATE SQL_TIME SQL_TIMESTAMP
SQL_LONGVARCHAR SQL_BINARY SQL_VARBINARY SQL_LONGVARBINARY
SQL_BIGINT SQL_TINYINT
SQL_WCHAR SQL_WVARCHAR SQL_WLONGVARCHAR
SQL_BIT
) ],
utils => [ qw(
neat neat_list dump_results looks_like_number
) ],
);
Exporter::export_ok_tags('sql_types', 'utils');

$DBI::dbi_debug = $ENV{DBI_TRACE} || $ENV{PERL_DBI_DEBUG} || 0;


# If you get an error here like "Can't find loadable object ..."
# then you haven't installed the DBI correctly. Read the README
# then install it again.
bootstrap DBI;


Version von Perl: 5.8.0.806 (ActiveState)

Um welches "lodable object" handelt es sich ?
Wie installieren ?

Danke für Eure Hilfe
jan
 2004-02-18 11:41
#48626 #48626
User since
2003-08-04
2536 articles
ModeratorIn
[Homepage] [default_avatar]
Quote
# If you get an error here like "Can't find loadable object ..."
# then you haven't installed the DBI correctly. Read the README
# then install it again.
Baerli
 2004-02-18 11:57
#48627 #48627
User since
2004-01-15
17 articles
BenutzerIn
[default_avatar]
[quote=jan,18.02.2004, 10:41]
Quote
# If you get an error here like "Can't find loadable object ..."
# then you haven't installed the DBI correctly. Read the README
# then install it again.
[/quote]
in README steht nur:
Code: (dl )
1
2
3
4
To install this ActiveState PPM package, run the following command
in the current directory:

   ppm install DBI.ppd


alles ausprobiert:
ppm install DBI.ppd
ppm install DBI

unter dem ppm-Prompt: install DBI.ppd
                                install DBI

Es tut sich nichts. (Keine Meldung,...)
Nach 10 min. breche ich ab.

Gruss
havi
 2004-02-18 11:58
#48628 #48628
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Code: (dl )
1
2
3
4
5
6
Internetverbindung aufbauen
cmd.exe oeffnen
ppm
install DBI
quit
exit


Gruss
Baerli
 2004-02-18 12:11
#48629 #48629
User since
2004-01-15
17 articles
BenutzerIn
[default_avatar]
Das funktioniert ja nicht.

In den letzten Wochen habe ich mir (als Anfänger) immer wieder stundenlang an einem Problem die Zähne ausgebissen,
(Server installieren, SQL-DB installieren, ODBC-Treiber,...),
kam aber immer wieder mit Hilfe von Internet-Seiten (auch mit dieser) weiter.


 ??? Jetzt bin ich ratlos.

Internetverbindung existiert
in der Kommandozeile: Aufruf von ppm (funktioniert)
Eingabe: install DBI

Dann Funkstille und keine Eingabe mehr möglich.
Nach 5-10 min. beende ich den Task.

Gruss
havi
 2004-02-18 12:14
#48630 #48630
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Was hast du fuer Rechte?
Ronnie
 2004-02-18 12:14
#48631 #48631
User since
2003-08-14
2022 articles
BenutzerIn
[default_avatar]
install DBI kann nicht funktionieren! du must erst danach suchen - siehe die Posts weiter oben! sollte ppm auch beim suchen nichts finden, musst du evtl. einen Proxy angeben wenn du hinter einer Firewall sitzt.
havi
 2004-02-18 12:15
#48632 #48632
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Stimmt nicht. Du musst vorher nicht danach suchen!

Probier es mal mit Adminrechten.

Gruss
Crian
 2004-02-18 12:17
#48633 #48633
User since
2003-08-04
5866 articles
ModeratorIn
[Homepage]
user image
Sitzt Du vielleicht hinter einem Proxi?
s--Pevna-;s.([a-z]).chr((ord($1)-84)%26+97).gee; s^([A-Z])^chr((ord($1)-52)%26+65)^gee;print;

use strict; use warnings; Link zu meiner Perlseite
Baerli
 2004-02-18 13:48
#48634 #48634
User since
2004-01-15
17 articles
BenutzerIn
[default_avatar]
[quote=Crian,18.02.2004, 11:17]Sitzt Du vielleicht hinter einem Proxi?[/quote]
Nein, normale DFÜ-Verbindung zu t-online

und bin User mit Admin-Rechten
<< |< 1 2 3 4 >| >> 36 entries, 4 pages



View all threads created 2004-02-17 22:25.