Font
Wiki:Tipp zum Debugging: use Data::Dumper; local $Data::Dumper::Useqq = 1; print Dumper \@var;
[thread]9646[/thread]

Netzwerkprobleme?



<< |< 1 2 3 4 >| >> 35 entries, 4 pages
skontox
 2003-12-18 11:01
#96412 #96412
User since
2003-08-06
193 articles
BenutzerIn
[default_avatar]
Guten Tag!
Ich hab hier ein kleines Problem.
Wie kann ich herausbekommen, ob bei mir ne Firewall oder irgendetwas in der Art läuft und unterbindet, dass ich von außen auf mein Server-Programm mit Port 9999 zugreifen kann.

Muß ich noch irgendetwas berücksichtigen oder Rechte vergeben?

Lokal ist das überhaupt kein Problem, aber sobald ich client und server im Netz verteile bekomme ich Probleme.

Die Programme sind zwar keine Perl Programme, aber da hier wahrscheinlich viele Linux Cracks sind, dachte ich frag ich mal einfach nach.

OK unter Yast2 habe ich das Häckchen bei der DSL-Verbindung Firewall aktiviert weg genommen, aber vielleicht läuft dort standardmäßig noch eine andere Firewall.
Achso, ich benutze Suse Linux 8.2

Gruß skontox
havi
 2003-12-18 11:20
#96413 #96413
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Was sagen die hoffentlich vorhandenen Logfiles?
skontox
 2003-12-18 11:20
#96414 #96414
User since
2003-08-06
193 articles
BenutzerIn
[default_avatar]
Vielleicht hilf es euch und natürlich mir, wenn ich mal kurz aufzeige was für Prozesse auf meiner Kiste laufen:

Ich hab das Komando
"ps -A" in der Shell eingegeben und das ausgegeben bekommen:

PID TTY TIME CMD
1 ? 00:00:05 init
2 ? 00:00:00 keventd
3 ? 00:00:00 kapmd
4 ? 00:00:00 ksoftirqd_CPU0
5 ? 00:00:00 kswapd
6 ? 00:00:00 bdflush
7 ? 00:00:00 kupdated
8 ? 00:00:00 kinoded
10 ? 00:00:00 mdrecoveryd
13 ? 00:00:00 kreiserfsd
151 ? 00:00:00 lvm-mpd
636 ? 00:00:00 atd
844 ? 00:00:00 eth0
850 ? 00:00:00 dhcpcd
910 ? 00:00:00 syslogd
913 ? 00:00:00 klogd
973 ? 00:00:00 khubd
1221 ? 00:00:00 resmgrd
1246 ? 00:00:00 portmap
1329 ? 00:00:00 nscd
1330 ? 00:00:00 nscd
1331 ? 00:00:00 nscd
1332 ? 00:00:00 nscd
1333 ? 00:00:00 nscd
1334 ? 00:00:00 nscd
1335 ? 00:00:00 nscd
1373 ? 00:00:00 sshd
1421 ? 00:00:00 master
1450 ? 00:00:00 qmgr
1480 ? 00:00:00 cron
1513 ? 00:00:00 smpppd
1732 ? 00:00:00 kdm
1757 tty1 00:00:00 mingetty
1758 tty2 00:00:00 mingetty
1759 tty3 00:00:00 mingetty
1760 tty4 00:00:00 mingetty
1761 tty5 00:00:00 mingetty
1762 tty6 00:00:00 mingetty
1763 ? 00:01:52 X
1764 ? 00:00:00 kdm
1791 ? 00:00:00 kde
1819 ? 00:00:00 kdeinit
1822 ? 00:00:00 kdeinit
1825 ? 00:00:00 kdeinit
1828 ? 00:00:00 kdeinit
1841 ? 00:00:00 artsd
1843 ? 00:00:00 kdeinit
1846 ? 00:00:00 kwrapper
1848 ? 00:00:00 kdeinit
1849 ? 00:00:07 kdeinit
1851 ? 00:00:00 kdeinit
1853 ? 00:00:01 kdeinit
1856 ? 00:00:02 kdeinit
1860 ? 00:00:04 appletproxy
1861 ? 00:00:05 appletproxy
1862 ? 00:00:00 appletproxy
1863 ? 00:00:01 appletproxy
1865 ? 00:00:00 kdeinit
1869 ? 00:00:00 kinternet
1870 ? 00:00:00 susewatcher
1878 ? 00:00:00 nspluginviewer
1879 ? 00:00:04 kdeinit
1881 ? 00:00:00 kalarmd
1883 ? 00:00:00 smpppd-ifcfg
1892 ? 00:00:00 pppd
2032 ? 00:01:18 mozilla-bin
2058 ? 00:00:00 mozilla-bin
2059 ? 00:00:00 mozilla-bin
2060 ? 00:00:00 mozilla-bin
2061 ? 00:00:00 mozilla-bin
2105 ? 00:00:00 kdeinit
2166 ? 00:00:08 kdeinit
2167 ? 00:00:02 kdeinit
2168 pts/1 00:00:00 bash
2222 ? 00:00:00 netstat <defunct>
2225 ? 00:00:08 kdeinit
2226 ? 00:00:02 kdeinit
2227 pts/2 00:00:00 bash
2446 ? 00:00:00 pickup
2447 ? 00:00:00 mozilla-bin
2475 ? 00:00:01 kdeinit
2476 ? 00:00:00 kdeinit
2502 pts/1 00:00:00 perl
2548 pts/2 00:00:00 ps


Ich kann leider nicht mit allen dingen was anfangen, aber vielleicht Ihr und seht da noch ein Prozess der ne Firewall oder soetwas sein kann.

Gruß skontox
havi
 2003-12-18 11:20
#96415 #96415
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Da haben wir uns wohl mit dem posten ueberschnitten, aber
egal, was sagen den die Logfiles?\n\n

<!--EDIT|havi|1071739348-->
skontox
 2003-12-18 11:22
#96416 #96416
User since
2003-08-06
193 articles
BenutzerIn
[default_avatar]
Hallo havi, Du warts wohl etwas schneller als ich.
wo finde ich denn diese Logfiles? Oder muß&´ ich die erst aktivieren.

Tut mir leid, dass ich so blöd frage, bin aber noch nicht so lange bei Linux dabei

Gruß skontox
havi
 2003-12-18 11:23
#96417 #96417
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Ich arbeite auch unter Windows, darum meinte ich ja, hoffentlich vorhandene Logfiles.
skontox
 2003-12-18 11:29
#96418 #96418
User since
2003-08-06
193 articles
BenutzerIn
[default_avatar]
Ich hab mal eben schnell nen kleine Perl server-client-Anwendung geschrieben zum testen. Vielleicht kannst Du das ja mal ausprobieren.

Beim mir läuft der server auf port 9999.

hier der Code für den Client:
Code: (dl )
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#!/usr/bin/perl -w

use IO::Socket;
use strict;

if($ARGV[0] and $ARGV[1])
{
my $remote_host = $ARGV[0];
my $remote_port = $ARGV[1];
my $socket = IO::Socket::INET->new(PeerAddr => $remote_host,
PeerPort => $remote_port,
Proto => "tcp",
Type => SOCK_STREAM)
or die "Couln't connect to $remote_host:$remote_port: $@\n";

print $socket "1\n";
#sleep(2);
print $socket "2\n";
my $answer = <$socket>;
print "Receiving: $answer\n";
close ($socket);
#sleep(5);
}
else
{
print "Sorry you have to tell the client the IPadress and Portadress of the server!-> e.g: perl client.pl 194.94.217.81 9999\n";
}


einfach ausführen mit "perl client 217.85.3.211 9999

Wäre lieb, wenn Du das mal testen könntest und mir sagen was Du empfängst

eigentlich sollte das bei Dir stehen:
Receiving: 3

Gruß skontox
havi
 2003-12-18 11:37
#96419 #96419
User since
2003-08-04
2036 articles
BenutzerIn
[Homepage]
user image
Ausgabe:
Code: (dl )
Couln't connect to 217.85.3.211:9999: IO::Socket::INET: connect: Unknown error
skontox
 2003-12-18 11:41
#96420 #96420
User since
2003-08-06
193 articles
BenutzerIn
[default_avatar]
Jetzt hast du mir einen großen gefallen getan! ;-)

Denn nun weiß ich dass es auf jeden Fall am Netzwerk liegen muß!
Das ist schon mal sehr gut. Fehler ist schon mal eingekreist.

Denn die gleiche Anwendung habe ich schon x-mal unter Windows probiert und dort lief sie wunderbar.

Danke erstmal, jetzt muß ich nur herausbekommen, warum das so ist, wo der Fehler liegen kann.

Gruß skontox
skontox
 2003-12-18 11:49
#96421 #96421
User since
2003-08-06
193 articles
BenutzerIn
[default_avatar]
Oder hast Du ne dicke Firewall installiert?

Gruß skontox
<< |< 1 2 3 4 >| >> 35 entries, 4 pages



View all threads created 2003-12-18 11:01.